PAT A1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A + B A+B A+B where A A A and B B B are two polynomials.

Input Specification

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K   N 1   a N 1   N 2   a N 2   . . .   N K   a N K K\ N_1\ a_{N_1}\ N_2\ a_{N_2}\ ...\ N_K\ a_{N_K} K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, N i N_i Ni and a N i a_{N_i} aNi ( i = 1 , 2 , ⋯ , K i=1,2,⋯,K i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 1≤K≤10 1K10
0 ≤ N K < ⋯ < N 2 < N 1 ≤ 1000 0≤N_K <⋯<N_2<N_1 ≤1000 0NK<<N2<N11000.

Output Specification

For each test case you should output the sum of A A A and B B B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

题解

题意

计算多项式 A + B A+B A+B 的和。

思路

多项式的次数的范围较小,可以使用哈希直接映射。输出时从后往前输出所有系数不为 0 的指数和系数。

代码

#include <cstdio>

#define M 1005

double poly[M];

int main() {
  double q;
  int k, p, cnt = 0;

  for (int i = 0; i < 2; ++i) {
    scanf("%d", &k);
    for (int j = 0; j < k; ++j) {
      scanf("%d %lf", &p, &q);
      poly[p] += q;
    }
  }

  for (int i = 0; i < M; ++i) {
    if (poly[i] != 0) {
      ++cnt;
    }
  }

  printf("%d", cnt);

  if (cnt) {
    for (int i = M - 1; i >= 0; --i) {
      if (poly[i] != 0) printf(" %d %.1f", i, poly[i]);
    }
  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值