F - Goldbach`s Conjecture(素数筛)

Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.
Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1) Both a and b are prime

2) a + b = n

3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1

Case 2: 1
Hint
An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
using namespace std;
bool p[12345678];
vector<int> ma;
void isprime()
{
   memset(p, true, sizeof(p));
   p[1] = false;
   for(int i=2;i<12345678;i++)//素数筛
   {
      if(p[i])
      {
         for(int j=2*i;j<12345678;j+=i)
         {
            p[j] = false;
         }
      }
   }
   for(int i=2;i<12345678;i++)//把每一个素数存下来,以防后来遍历超时
   {
     if(p[i])
     ma.push_back(i);//存素数
   }
}
int main()
{
  int T;
  isprime();
  scanf("%d", &T);
  for(int t=1;t<=T;t++)
  {
    int n;
    scanf("%d", &n);
    long long int ans = 0;
    for(int i=0;ma[i]<=n/2;i++)
    {
        int b = n - ma[i];
        if(p[b])
        ans++;
    }
    printf("Case %d: %lld\n", t, ans);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值