hdu 5742 chess SG函数

Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1908    Accepted Submission(s): 831


Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.
 

Input
Multiple test cases.

The first line contains an integer  T(T100) , indicates the number of test cases.

For each test case, the first line contains a single integer  n(n1000) , the number of lines of chessboard.

Then  n  lines, the first integer of ith line is  m(m20) , indicates the number of chesses on the ith line of the chessboard. Then m integers  pj(1pj20) followed, the position of each chess.
 

Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.
 

Sample Input
  
  
2 1 2 19 20 2 1 19 1 18
 

Sample Output
  
  
NO YES


题意:给n堆石子,有两种操作,第一种是选择任意一堆取走一些石子,可以取完这一堆,但不能不取。第二种操作是把某一堆分成三堆石子,每堆石子不能为空。问先手是否必胜。


SG函数,因为数据是1e9,所以打表找一下规律。

#include <bits/stdc++.h>

using namespace std;

int SG[1000];
int sg(int x)
{
    if(SG[x] != -1) return SG[x];
    int vis[150] = {0};
    for(int i = 1;i <= x;i++)     ///正常的nim取石子
        vis[sg(x-i)] = 1;
    for(int i = 1;i <= 100;i++){  ///采用另一种操作,分成三堆
        for(int j = 1;j <= 100;j++){
            for(int k = 1;k <= 100;k++){
                if(i+j+k == x){
                    vis[sg(i)^sg(j)^sg(k)] = 1;
                }
            }
        }
    }
    for(int i = 0;;i++)
        if(!vis[i]) return SG[x] = i;
}

void Init()
{
    memset(SG,-1,sizeof SG);
    SG[0] = 0;
    SG[1] = 1;
    SG[2] = 2;
    sg(100);
    for(int i = 0;i <= 100;i++) printf("%d %d\n",i,SG[i]);
}

int SG_(int x)
{
    if(x%8 == 7) return x+1;
    if(x%8 == 0) return x-1;
    return x;
}

int main()
{
    //Init();  打表找规律
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        int ans = 0;
        for(int i = 1;i <= n;i++){
            int t;
            scanf("%d",&t);
            ans ^= SG_(t);
        }
        if(ans) puts("First player wins.");
        else    puts("Second player wins.");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值