Bloodsucker ZOJ - 3551

概率论
题目:In 0th day, there are n-1 people and 1 bloodsucker. Every day, two and only two of them meet. Nothing will happen if they are of the same species, that is, a people meets a people or a bloodsucker meets a bloodsucker. Otherwise, people may be transformed into bloodsucker with probability p. Sooner or later(D days), all people will be turned into bloodsucker. Calculate the mathematical expectation of D.

Input
The number of test cases (T, T ≤ 100) is given in the first line of the input. Each case consists of an integer n and a float number p (1 ≤ n < 100000, 0 < p ≤ 1, accurate to 3 digits after decimal point), separated by spaces.

Output
For each case, you should output the expectation(3 digits after the decimal point) in a single line.

Sample Input
1
2 1

Sample Output
1.000
题意:n-1人,1吸血鬼,每天有两个人遇见,只有人和吸血鬼遇见会触发概率事件,同化吸血鬼,全部同化的期望。

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<sstream>
#include<iostream>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#include<iomanip>
#define ll long long
using namespace std;
double f[100010],g[100010],a[100010];
int main()
{
    int n,t;
    double s1,s2,s3,d;
    scanf("%d",&n);
    while(n--){
    	scanf("%d%lf",&t,&d);
    	f[t]=0;
    	for(int i=t-1;i>=1;i--){
    		s1=(double)t*(t-1)/2;
            s2=(double)i*(t-i);
            s3=s2/s1*d;
    		f[i]=(f[i+1]*s3+1)/s3;
		}printf("%.3lf\n",f[1]);
	}
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值