PAT A1001 A+B Format (20分)

题目:

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

思路:1、计算a+b的和sum。2、将sum按位存到数组中。3、倒序输出并在合适位置加逗号。

注意:1、如99111,存到数组中是11199。输出是从数组尾部开始,每三位加逗号是从数组头开始数,即:应为99,111;而非991,11.。判断条件:i%3==0(i为数组下标)而非 flag%3==0(flag为输出数字的个数)

2、每三位加逗号,但若末位刚好为3的倍数,不加逗号。即:“991,111”而非“991,111,”

#include<iostream>
#include<vector>

using namespace std;

int main()
{
    long long a, b, sum;
    cin >> a >> b;
    sum = a+b;
    if(sum==0)
    {
        cout << 0;
        return 0;
    }
    if(sum<0)
    {
        cout << '-';
        sum = -sum;
    }
    vector<int> ans;
    while(sum!=0)
    {
        ans.push_back(sum%10);
        sum /=10;
    }
    for(int i=ans.size()-1; i>=0; i--)
    {
        cout << ans[i];
        if(i%3==0 && i!=0)
        {
            cout << ',';
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值