1146. Topological Order (25)

1146. Topological Order (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (<= 1,000), the number of vertices in the graph, and M (<= 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (<= 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4

此题如果理解了拓扑排序的算法思想,不难!


#include <iostream>
#include <vector>
using namespace std;
int no[1001] = { 0 }, no_c[1001] = { 0 }, test[1001];
vector<int>v[1001], vx;
int main() {
	int n, m, a, b, k;
	cin >> n >> m;
	for (int i = 1; i <= m; i++) {
		cin >> a >> b;
		v[a].push_back(b);//顶点a出度指向的顶点集合
		no[b]++;//顶点入度增加
	}
	cin >> k;
	for(int s=0;s<k;s++) {
		for (int i = 0; i < 1001; i++)
			no_c[i] = no[i];//因为要验证多个测试用例,所以顶点入度集合需要建立副本
		for (int i = 0; i < n; i++)
			cin >> test[i];
		bool flag = true;
		for (int i = 0; i < n; i++) {
			if (no_c[test[i]] != 0)
			{
				flag = false; break;
			}
			else for (int j = 0; j < v[test[i]].size(); j++)
				no_c[v[test[i]][j]]--;
		}
		if (!flag) vx.push_back(s);
	}
	cout << vx[0];
	for (int i = 1; i < vx.size(); i++)
		cout << " " << vx[i];
	cout << endl;
	//system("pause");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值