PAT真题练习(甲级)1107 Social Clusters (30 分)

PAT真题练习(甲级)1107 Social Clusters (30 分)

原题网址:https://pintia.cn/problem-sets/994805342720868352/problems/994805361586847744

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

where K​i(>0) is the number of hobbies, and​i[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input :

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output :

3
4 3 1

思路 :

在实际的实现过程中碰到了挺多易错点的,下面列举一些:

  1. 两个集合并集的时候要注意,所有所属爱好的集合id都要更改。其中包括这一次读入的爱好序列中,未包含的。
  2. 集合合并计算个数的时候要注意,不要对相同的集合重复合并
  3. 记得更新 新读入的爱好所属集合id

AC代码

#include <stdio.h>
#include <iostream>
#include <stack>
#include <vector>
#include <string>
#include<math.h>
#include<unordered_map>
#include<algorithm>
using namespace std;

int main() {
	int N;
	cin >> N;
	vector<int> clusters;
	unordered_map<int, int> hobbies;
	for (auto i = 0;i < N;i++) {
		int K;
		cin >> K;
		// 读入冒号
		getchar();
		vector<int> my_hobby(K);
		vector<int> my_cluster;
		for (auto j = 0; j < K;j++) {
			cin >> my_hobby[j];
			if (hobbies.find(my_hobby[j]) != hobbies.end()) {
				my_cluster.push_back(hobbies[my_hobby[j]]);
			}
		}
		if (my_cluster.size() == 0) {
			clusters.push_back(1);
			for (auto j = 0; j < K;j++) {
				hobbies[my_hobby[j]] = clusters.size() - 1;
			}
		}
		else if (my_cluster.size() == 1) {
			clusters[my_cluster[0]] ++;
			for (auto j = 0; j < K;j++) {
				hobbies[my_hobby[j]] = my_cluster[0];
			}
		}
		else {
			clusters[my_cluster[0]]++;
			for (auto j = 1; j < my_cluster.size();j++) {
			// 注意点2
				if (my_cluster[0] == my_cluster[j]) continue;
				clusters[my_cluster[0]] += clusters[my_cluster[j]];
				clusters[my_cluster[j]] = 0;
				// 注意点1
				for (auto item : hobbies) {
					if (item.second == my_cluster[j])  hobbies[item.first] = my_cluster[0];
				}
			}
			for (auto j = 0; j < K;j++) {
				hobbies[my_hobby[j]] = my_cluster[0];
			}
		}

	}

	sort(clusters.begin(), clusters.end());
	reverse(clusters.begin(), clusters.end());
	int i = 0;
	for (i = 0; i < clusters.size();i++) {
		if (clusters[i] == 0) break;
	}
	cout << i << endl;
	for (auto i = 0; i < clusters.size();i++) {
		if (clusters[i] == 0) break;
		if (i != 0) cout << " ";
		cout << clusters[i];
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值