##【并查集判环】UVALive 3644 X-Plosives 【简单建模 — 判断是否有 n个简单化合物 组成n种炸药 的情况】
A secret service developed a new kind of explosive that attain its volatile property only when a specific association of products occurs. Each product is a mix of two different simple compounds, to which we call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.
You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in the same room an explosive association. So, after placing a set of pairs, if you receive one pair that might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you must accept it.
An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds). Finally, you would accept the last pair, F+H.
Compute the number of refusals given a sequence of binding pairs.
Input
The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single blank line.
Instead of letters we will use integers to represent compounds. The input contains several lines. Each line (except the last) consists of two integers (each integer lies between 0 and 10 5) separated by a single space, representing a binding pair.
Each test case ends in a line with the number ‘ -1’. You may assume that no repeated binding pairs appears in the input.
Output
For each test case, the output must follow the description b elow.
A single line with the number of refusals.
Sample Input
1 2
3 4
3 5
3 1
2 3
4 1
2 6
6 5
-1
Sample Output
3
题意:
每一种结合剂由两种不同的简单化合物构成,当混合N个不同的结合剂,且它们总共包含N个简单化合物时,会产生爆炸。
给你一些表示结合剂的序列,当可能产生爆炸时,你需要拒绝这个序列,否则必须接受。问拒绝的数量。
思路:
将简单化合物看做顶点,结合剂看做两个点的之间的边,当出现环的时候,就会出现N个结合剂包含N种简单化合物的情况。所以可以用并查集进行判环。
AC代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn = 100005;
int fa[maxn];
void init()
{
for(int i = 0; i <= 100000; i++)
fa[i] = i;
}
int Find(int x)
{
return fa[x] == x ? x : fa[x] = Find(fa[x]);
}
void Merge(int x, int y)
{
int fx = Find(x), fy = Find(y);
if(fx != fy)
fa[fx] = fy;
}
int main()
{
int a, b, cnt;
init();
cnt = 0;
while(~scanf("%d", &a))
{
if(a == -1)
{
printf("%d\n", cnt);
init();
cnt = 0;
continue ;
}
scanf("%d", &b);
if(Find(a) == Find(b))
cnt++;
else
Merge(a, b);
}
return 0;
}