UVALive 3644 X-Plosives 并查集

X-Plosives

A secret service developed a new kind of explosive that attain its volatile property only when a specific association of products occurs. Each product is a mix of two different simple compounds, to which we call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.


You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive
binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in
the same room an explosive association. So, after placing a set of pairs, if you receive one pair that
might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you
must accept it.
An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,
F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the
following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).
Finally, you would accept the last pair, F+H.
Compute the number of refusals given a sequence of binding pairs.
Input
The input will contain several test cases, each of them as described below. Consecutive
test cases are separated by a single blank line.

Instead of letters we will use integers to represent compounds. The input contains several lines.
Each line (except the last) consists of two integers (each integer lies between 0 and 10 5) separated by
a single space, representing a binding pair.
Each test case ends in a line with the number ‘ -1’. You may assume that no repeated binding pairs
appears in the input.
Output
For each test case, the output must follow the description b elow.
A single line with the number of refusals.
Sample Input
1 2
3 4
3 5
3 1
2 3
4 1
2 6
6 5
-1
Sample Output
3


将元素视为顶点,化合物视为边,则可将题目转化为添加一条边进去后是否生成环

故可用并查集判环

#include<cstdio>

using namespace std;

int fa[100100];///储存每个节点的父节点

int father(int x) {
    return fa[x] == x ? x : fa[x] = father(fa[x]);///如果某节点的父节点还是它本身,那么他就是最顶端的,停止查找
}		<span style="white-space:pre">				</span>///否则继续找父节点的父节点,并修改其父节点为顶端的点(路径压缩)

int main(void) {

    int a,b;
    while(~scanf("%d",&a)) {
        int cnt = 0;
        for(int i = 0; i < 100100; ++i)
            fa[i] = i;///初始化fa数组,每个元素的fa为自己本身
        while(a != -1) {
            scanf("%d",&b);
            if(father(a) == father(b))///【查】询a与b是否属于同一集合(即加入ab后,原图是否产生环)
                cnt++;
            else
                fa[fa[a]] = fa[b];///将a、b【并】入同一集合(即增加边ab),注意是fa[fa[a]]不是fa[a]]
            scanf("%d",&a);

        }
        printf("%d\n",cnt);

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值