杭电5146题

Problem Description
Today we have a number sequence A includes n elements.
Nero thinks a number sequence A is good only if the sum of its elements with odd index equals to the sum of its elements with even index and this sequence is not a palindrome.
Palindrome means no matter we read the sequence from head to tail or from tail to head,we get the same sequence.
Two sequence A and B are consider different if the length of A is different from the length of B or there exists an index i that  AiBi .
Now,give you the sequence A,check out it’s good or not.
 

Input
The first line contains a single integer T,indicating the number of test cases.
Each test case begins with a line contains an integer n,the length of sequence A.
The next line follows n integers  A1,A2,,An .

[Technical Specification]
1 <= T <= 100
1 <= n <= 1000
0 <=  Ai  <= 1000000
 

Output
For each case output one line,if the sequence is good ,output "Yes",otherwise output "No".
 

Sample Input
  
  
3 7 1 2 3 4 5 6 7 7 1 2 3 5 4 7 6 6 1 2 3 3 2 1
 

Sample Output
  
  
No Yes No
 
(就是判断一个数列的奇数项和与偶数项和是否相等,若相等且不是回文数列,则为好的数列)
#include <iostream>
using namespace std;
int x[1000000];

int main()
{
	int m,n,s1,s2;
	int i,j;
	cin >> m;
	while (m--)
	{
		cin >> n;
		s1 = s2 = 0;
		for (i = 0; i < n; i++) 
		{
			cin >> x[i];
			if(( i + 1 ) % 2 == 0) s2 += x[i];
			else s1 += x[i];
		}//判断数列奇数项和偶数项之和是否相等
		if(s1 == s2)
		{
			s1 = s2 =0;
			for(i = 0, j = n - 1; i <= n / 2; i++, j--)
			{
				s1 += x[i];
				s2 += x[j];
			} //判断是否为回文数列
			if(s1 == s2) cout << "No" << endl;
			else cout << "Yes" << endl;
		}
		else cout << "No" << endl;
	}
	return 0;
}

(鄙人还是新手,代码写的比较烂 大笑。欢迎各位高手留言,对代码精简完善 微笑
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值