uva465 - Overflow

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big

因为只要判断比int大还是小明显可以偷懒。百度了下maxint=2147483647;只有10位数字;所以读入串去掉前导0超过10位的一定大于maxint了没必要求出他本身多大直接给他赋值maxint+n,n大于1随你喜欢太大可不好哟。如果小于等于10位那就转换成实数,因为涉及乘法转换成整形会越界。如此如此就解决了。

百度的时候看到都用atof函数,好东西啊,可是他转换也是在实数范围的-1.7*10^(-308) ~ 1.7*10^308,所以数据弱了没超过308位的数字。╮(╯▽╰)╭

 

#include <stdio.h>
#include <string.h>
double max=2147483647;
double sort(char s[])
{int l=strlen(s),pos=0,i;
 double num=0;
 if (s[pos]=='+') --pos;
 while ((pos<l)&&(s[pos]=='0')) ++pos;
 if (l-pos>10) return max+1;
 for (i=pos;i<l;i++)
 num=num*10+s[i]-'0';
 return num;
};
void main()
{char s1[1000],s2[1000],lable;
 double num1,num2;
 while (scanf("%s %c %s",&s1,&lable,&s2)!=EOF)
 {num1=sort(s1);
  num2=sort(s2);
  printf("%s %c %s\n",s1,lable,s2);
  if (num1>max) printf("first number too big\n");
  if (num2>max) printf("second number too big\n");
  if (lable=='+') num1+=num2;
             else num1*=num2;
  if (num1>max) printf("result too big\n");
 }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值