uva 532 - Dungeon Master

Dungeon Master 

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.


Is an escape possible? If yes, how long will it take?

Input Specification 

The input file consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).


L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.


Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a `#' and empty cells are represented by a `.'. Your starting position is indicated by `S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output Specification 

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form


Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line


Trapped!

Sample Input 

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output 

Escaped in 11 minute(s).
Trapped!
六个方向的BFS,队列数组定义错了runtime error无数次真无语
#include<stdio.h>
#define size 31
struct node
{int x,y,z,time;
}queue[size*size*size];  //二维的bfs写多了,果然2了,这是三维的开始定义成size*size,郁闷
char s[size][size][size];
int f,l,r,c,top,tail,visit[size][size][size],move[6][3]={0,1,0,0,-1,0,0,0,1,0,0,-1,1,0,0,-1,0,0};
int Bfs()
{int i,px=queue[top].x,py=queue[top].y,pz=queue[top].z,X,Y,Z;
 if (f) return 0;
 if (s[px][py][pz]=='E') {f=1; return 0;}
 if (top>tail) return 0;
 for (i=0;i<6;i++)
 {X=px+move[i][0];
  Y=py+move[i][1];
  Z=pz+move[i][2];
  if ((X>0)&&(X<=l)&&(Y>0)&&(Y<=r)&&(Z>0)&&(Z<=c)&&(s[X][Y][Z]!='#')&&(visit[X][Y][Z]==1))
  {++tail;
   queue[tail].x=X;
   queue[tail].y=Y;
   queue[tail].z=Z;
   queue[tail].time=queue[top].time+1;
   visit[X][Y][Z]=0;   //开始漏了这个,以为每次BFS的时候再标记就可以了,但是这样可能会造成,同一层的点扩展到一层的点重复的问题。
  }
 }
 ++top;
 Bfs();
};
int main()
{int i,j,k;
 while (scanf("%d%d%d",&l,&r,&c),l+r+c)
 {
  for (i=1;i<=l;i++)
  {getchar();
   for (j=1;j<=r;j++)
   {for (k=1;k<=c;k++)
    {scanf("%c",&s[i][j][k]);
     visit[i][j][k]=1;
     if (s[i][j][k]=='S')
     {queue[1].x=i; queue[1].y=j;
      queue[1].z=k; queue[1].time=0;
	  visit[i][j][k]=0;
     }
    }
    getchar();
   }
  }
  top=1; tail=1; f=0;
  Bfs();
  if (f) printf("Escaped in %d minute(s).\n",queue[top].time);
    else printf("Trapped!\n");
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值