Bi-shoe and Phi-shoe LightOJ - 1370

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:给你一个数n,假设小于它的数有x个与它互质,我们称它的价值是x。给你一个价值,让你找对应的一个数,这个数的价值大于等于题目所给的价值,且必须最小,题目一共给你n个价值,你要找n个数,并加和就好了。
最朴素的做法是根据定义找每个数的价值,然后打成一张表,然后一个个去比对,但是那样会超时。
所以可以用欧拉函数,它将直接为你打印一张每个数的价值表,当我们知道一个数x的价值时,直接从表中的x位置去搜寻,直到找到一个位置,那个位置的值大于即可

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const int Max = 1e6+10;
int phi[Max];
void Init()
{
    memset(phi,0,sizeof(phi));
    phi[1] = 1;
    for(int  i = 2; i < Max; i++)
    {
        if(!phi[i])
        {
            for(int j = i; j < Max ; j+=i)
            {
                if(!phi[j])
                    phi[j] = j;
                phi[j] = phi[j]/i*(i-1);
            }
        }
    }
}
int a[Max];
int main()
{
    int T,z = 1;
    int n;
    Init();
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        LL ans = 0 ;
        for(int i = 0; i < n ; i++)
        {
            int j = a[i]+1;
            while(phi[j]<a[i]) j++;
            ans+=j;
        }
        printf("Case %d: %lld Xukha\n",z++,ans);
    }
    return 0;
}

欧拉函数作用:求1-N的素数的工具
以下为筛选欧拉函数的代码
这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值