Discovering Gold LightOJ - 1030(期望+dp)

You are in a cave, a long cave! The cave can be represented by a 1 x N grid.
Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.
Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.
Sample Input

3
1
101  
2
10 3
3
3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

题解:一个棋盘,1行n列,每个格子有一个价值,从第一个格子出发,每次扔色子,扔几就在原来的基础上重新加几,扔的数超过n就重新扔,走到n结束,每个格子里都有对应的黄金数量,问获得这些黄金的期望。每次都从1开始走
比如样例3 若我们现处在格子1,那么E1=3+6*1/2+9*1/2(1格子的黄金已经拿走,那么只剩下两个格子,各是1/2)
若我们现处在格子2,那么E2=6+9
若我们现处在格子3,那么E3=9
因此由于数据量太大,只能借助dp完成,从第n个格子的期望开始算,一直加到第一个,那么dp[1]就是获得所有黄金的期望。
dp[i] = dp[i+1]/6+dp[i+2]/6+dp[i+3]/6+dp[i+4]/6+dp[i+5]/6+dp[i+6]/6;如果i+6>n的话,就要将除的6改成 n-i;

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
double dp[111];
int a[111];

int main()
{

    int t,n,mx;

    scanf("%d",&t);

    for(int z = 1; z <= t; ++z)
    {
        scanf("%d",&n);

        mx = 0;
        for(int i = 1; i <= n; ++i)
        {
            scanf("%d",&a[i]);
            mx += a[i];
        }

        memset(dp,0,sizeof(dp));

        for(int i = n; i >= 1; --i)
        {
            int b = 6;
           if(i+b > n) b = n-i;
            for(int j = 1; j <= b; ++j)
                dp[i] += dp[i+j]*1.0/b;

            dp[i] += a[i];
        }
        printf("Case %d: %.11f\n",z,dp[1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值