算法笔记练习 6.1 vector 问题 A: 【PAT A1039】Course List for Student

算法笔记练习 题解合集

题目链接

题目

题目描述
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

思路

自己写的时候既没想到哈希,STL 也没用好,完全还是 C 语言的思维,所以参考了柳婼的思路和代码

学到的东西:

  1. 记得用哈希,记得用哈希,记得用哈希;
  2. 大数组要开成全局变量;
  3. vector相比数组的优势在于变长,所以确定长度不变的数据可以用数组,不必无脑用vector
  4. 如果用了vector,请用配套的.push_back()插入数据,用.size()获得元素个数,不要再用 C 语言那套array[cnt++] = value;
  5. sort函数可以不写cmp,默认递增排序。

代码

#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;

int string_to_int(char *str) {
	int ret = 0;
	for (int i = 0; i < 3; ++i)
		ret = ret * 26 + str[i] - 'A';
	ret = ret * 10 + str[3] - '0';
	return ret;
}

const int MAX = 26 * 26 * 26 * 10 + 10;
vector<int> students[MAX];	// 大数组写在函数外面 

int main() {
	int n, k;
	char name[5];
	while (scanf("%d %d", &n, &k) != EOF) {
		memset(students, 0, sizeof(students));
		for (int i = 0; i != k; ++i) {
			int cno, stuNum;
			scanf("%d %d", &cno, &stuNum);
			for (int j = 0; j != stuNum; ++j) {
				scanf("%s", name);
				students[string_to_int(name)].push_back(cno);
			}
		} 
		for (int i = 0; i != n; ++i) {
			scanf("%s", name);
			int no = string_to_int(name);
			printf("%s %d", name, students[no].size());
			sort(students[no].begin(), students[no].end()); 
			for (auto it = students[no].begin(); it != students[no].end(); ++it)
				printf(" %d", *(it));
			putchar('\n'); 
		} 
	} 
	return 0;
} 
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值