POJ - 2965 The Pilots Brothers' refrigerator

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

题解:4X4的开关,由【-】和【+】组成,要求翻动最少的开关,使所有开关变为【-】,如果翻动(2,3),则对应的第2行的·所有开关以及第3列的所有开关都将翻动。

和黑白棋那道题类似,具体看代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
char s[5][5];
int mp[20][20],a[20][20],l,ans;
int check()//判定是否出现全【-】
{
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
            if(s[i][j]=='+')
                return 0;
    return 1;
}
void lin(int x,int y)//翻转此开关及对应开关
{
    for(int i=0; i<4; i++)
    {
        if(s[i][y]=='+')
            s[i][y]='-';
        else
            s[i][y]='+';
        if(i!=y)
        {
            if(s[x][i]=='+')
                s[x][i]='-';
            else
                s[x][i]='+';
        }
    }
}
void dfs(int x,int y,int num)
{
    if(check())
    {
        if(ans>num)
        {
            ans=num;
            for(int i=0; i<num; i++)
            {
                //return之后mp数组的值会改变,所以及时存入另一数组
                a[i][0]=mp[i][0];
                a[i][1]=mp[i][1];
            }
        }
        return ;
    }
    if(x==4)//最后一行搜过但仍未满足条件
        return ;
    lin(x,y);//翻转
    mp[num][0]=x;
    mp[num][1]=y;
    if(y==3)//y=3说明已经x行已经搜索完毕,所以换行
        dfs(x+1,0,num+1);
    else
        dfs(x,y+1,num+1);
    lin(x,y);//不翻转此开关或此开关不满足,调用lin函数回到之前状态
    if(y==3)
        dfs(x+1,0,num);
    else
        dfs(x,y+1,num);
}
int main()
{
    while(~scanf("%s",s[0]))
    {
        int i,j;
        ans=inf;
        l=0;
        for(i=1; i<4; i++)
            scanf("%s",s[i]);
        dfs(0,0,0);
        if(ans!=inf)
        {
            printf("%d\n",ans);
            for(i=0; i<ans; i++)
                printf("%d %d\n",a[i][0]+1,a[i][1]+1);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值