Proud Merchants

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
 

Input

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.
 

Output

For each test case, output one integer, indicating maximum value iSea could get.
 

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output

5
11

题解:有n件商品,m块钱,接下来n行p,q,v分别指:这个商品的价格,想买这个商品手里最少有q块钱,这个商品的价值

问买商品最多能有多少价值。

这道题隐隐知道要排序,但是怎么排序就是一头雾水了,看了这个才有些明白https://www.cnblogs.com/chuanlong/archive/2013/01/13/2858915.html

写的巨清晰,排了序就很简单了,用dp【x】判断花费x时获得的最大价值,每次比较买这件和不买这件价值最大的一个

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[5050];
struct node
{
    int p,q,v;
    int cha;
} mp[550];
bool cmp(node a,node b)
{
    return a.cha<b.cha;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int i,j;
        memset(dp,0,sizeof(dp));
        for(i=1; i<=n; i++)
        {
            scanf("%d%d%d",&mp[i].p,&mp[i].q,&mp[i].v);
            mp[i].cha=mp[i].q-mp[i].p;
        }
        sort(mp+1,mp+n+1,cmp);
        for(i=1; i<=n; i++)
            for(j=m; j>=mp[i].q; j--)
                dp[j]=max(dp[j],dp[j-mp[i].p]+mp[i].v);
        printf("%d\n",dp[m]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值