Unidirectional TSP

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check. 

This problem deals with finding a minimal path through a grid of points while traveling only from left to right. 

Given an m*n matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below. 


 

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited. 

For example, two slightly different 5*6 matrices are shown below (the only difference is the numbers in the bottom row). 




The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows. 

InputThe input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file. 

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits 
OutputTwo lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output. 

Sample Input
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10
Sample Output
1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19

题意:

给你一个nXm的格子,要求你从最左走到最右(不限制在某一点=^=,我天,真是蠢到家了,看别人代码才懂这一点)。要求你输出权值最小的路线(格子内的数字为本格的值,每一步所在的行),如果恰好有多条,则按字典序输出路线(比如某条权值相同路线某一点在第3行,两条路线分别走的第2,4行,这时选较小的第2行。)

每一格的走法如图所示:


注意:第一行和最后一行是相连的,类似圆柱。。。

漏点:看了别人代码倒着开始的,但是还不理解为啥,因为懒得想了。。。。等我精力过剩再。。。

贴代码。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int mp[20][110],dp[20][110],book[20][110];
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        memset(book,0,sizeof(book));
        int i,j;
        for(i=1; i<=n; i++)
            for(j=1; j<=m; j++)
                scanf("%d",&mp[i][j]);
        //从最右列开始
        for(j=m; j>0; j--) //列(这里为我自己加个愚蠢的注释嘤嘤嘤看最下)
            for(i=1; i<=n; i++) //行
            {
                if(j==m)
                {
                    dp[i][j]=mp[i][j];
                    book[i][j]=i;
                }
                else
                {
                    //因为权值相同时行按字典序排列,所以有些>=,有些>。
                    dp[i][j]=dp[i][j+1];
                    book[i][j]=i;
                    if(i==n)
                    {
                        if(dp[i][j]>=dp[1][j+1])
                        {
                            dp[i][j]=dp[1][j+1];
                            book[i][j]=1;
                        }
                        if(dp[i][j]>=dp[i-1][j+1])
                        {
                            dp[i][j]=dp[i-1][j+1];
                            book[i][j]=i-1;
                        }
                    }
                    else if(i==1)
                    {
                        if(dp[i][j]>dp[n][j+1])
                        {
                            dp[i][j]=dp[n][j+1];
                            book[i][j]=n;
                        }
                        if(dp[i][j]>dp[i+1][j+1])
                        {
                            dp[i][j]=dp[i+1][j+1];
                            book[i][j]=i+1;
                        }
                    }
                    else
                    {
                        if(dp[i][j]>=dp[i-1][j+1])
                        {
                            dp[i][j]=dp[i-1][j+1];
                            book[i][j]=i-1;
                        }
                        if(dp[i][j]>dp[i+1][j+1])
                        {
                            dp[i][j]=dp[i+1][j+1];
                            book[i][j]=i+1;
                        }
                    }
                    dp[i][j]+=mp[i][j];
                }
            }
        int ans=dp[1][1],f=1;
        for(i=1; i<=n; i++)
            if(dp[i][1]<ans)
            {
                ans=dp[i][1];
                f=i;
            }
        for(i=1; i<=m; i++)
        {
            if(i<m)
                printf("%d ",f);
            else
                printf("%d\n",f);
            f=book[f][i];
        }
        printf("%d\n",ans);
    }
    return 0;
}

哭

最右一列开始,发叉生长,让前面的每一列都能找到根源并有值。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值