Tree Recovery

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

题解:给你某个二叉树的前序遍历(根,左,右)和中序遍历(左,根,右),要求输出后序遍历(左,右,根)。

https://blog.csdn.net/kay_zhyu/article/details/8859059 

这篇博客使我略明白。第一个lin(递归找左子树,直到以这个为结点的左子树找完,l==0,返回找右子树),第二个lin(递归找右子树)。。。还是不太懂。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s1[110],s2[110],mp[110];
void lin(int l,char *s1,char *s2,char *mp)
{
    if(l<=0)
        return ;
    int t=strchr(s2,s1[0])-s2;//查找s2中首次出现s1[0]的位置
    lin(t,s1+1,s2,mp);//递归得到左子树
    lin(l-1-t,s1+t+1,s2+t+1,mp+t);//递归得到右子树
    mp[l-1]=s1[0];//每次把(前序遍历字符串中的第一个节点)放在后序遍历字符串的最后
}
int main()
{
    int n;
    while(~scanf("%s %s",s1,s2))
    {
        int l=strlen(s1);
        lin(l,s1,s2,mp);
        mp[l]='\0';
        printf("%s\n",mp);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值