POJ1035-Spell checker(模拟)

Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26867 Accepted: 9847

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

代码:

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include<cmath>
#include <stack>
#include<cstdlib>
#include <cstring>
#include<ctime>
using namespace std;
const int N =10005;
char dict[N][16];
int dictlen[N];
char word[55][16];
int dictcnt = 0,wordcnt = 0;
bool change(char* w,char* d){
	int notsame = 0;//记录不同字母个数
	while(*w){
		if(*w!=*d) notsame++;
		if(notsame>1) return false;
		w++;d++;
	}
	return true;
}
bool del(char* w, char* d){
	int notsame = 0;
	while(*w){
		if(*w!=*d){
			w++;
			notsame++;
			if(notsame>1) return false;
			continue;
		}
		w++;d++;
	}
	return true;
}
bool add(char* w,char* d){
	int notsame = 0;
	while(*w){
		if(*w!=*d){
			d++;
			notsame++;
			if(notsame>1) return false;
			continue;
		}
		w++;d++;
	}
	return true;
} 
int main(){
	//输入字典和单词 
	while(cin>>dict[dictcnt]&&dict[dictcnt++][0] != '#'); dictcnt--;
	while(cin>>word[wordcnt]&&word[wordcnt++][0] != '#'); wordcnt--;
	//初始化字典每个词的长度存入dictlen
	for(int i =0;i<dictcnt;i++) dictlen[i] = strlen(dict[i]);
	for(int i =0;i<wordcnt;i++){
		int d[N];//存放符合条件的字典地址 
		int cnt = 0;//数组d的指针
		int flag = 0;//标记字典中是否含有要找的词 
		int len = strlen(word[i]);
		//遍历字典寻找符合条件的词,将符合条件的词的地址存入d中 
		for(int j = 0;j < dictcnt;j++){
			if(len == dictlen[j]){//有同样的字或换一个字母就一样 
				if(!strcmp(dict[j],word[i])){
					flag = 1;
					break;
				}
				if(change(word[i],dict[j])){
					d[cnt++] = j;
				}
			}
			if(len - 1 == dictlen[j]){//单词删一个字母与字典相同 
				if(del(word[i],dict[j])){
					d[cnt++] = j;
				}
			}
			if(len + 1 == dictlen[j]){//单词添加一个字母与字典相同 
				if(add(word[i],dict[j])){
					d[cnt++] = j;
				}
			}
		}
		//输出结果
		if(flag) cout<<word[i]<<" is correct"<<endl;
		else{
			cout<<word[i]<<": ";
			for(int j =0;j<cnt;j++){
				cout<<dict[d[j]]<<" ";
			}
			cout<<endl;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值