POJ 2352 Stars(树状数组||线段树单点更新)

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41427 Accepted: 18055

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

题意:在一个坐标系中 有一些星星 按y坐标升序(y相等时,按x升序) 求每颗星星左下角有多少星星

由于y的顺序已经排好 新加入一个点就是等价于更新区间[x,x],然后要求左下有几个点就是询问区间[0,x]的和,x的值可能为0,所以根节点的区间[0,maxn]。

//poj 2352 Stars  线段树的单点更新 
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=32000+10;
int sum[maxn<<2],level[maxn];

void Pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void update(int p,int l,int r,int rt)
{
	if(l==r)
	{
		sum[rt]++;
		return;
	}
	int mid=(l+r)>>1;
	if(p<=mid) update(p,l,mid,rt<<1);
	if(p>mid)  update(p,mid+1,r,rt<<1|1);
	Pushup(rt);
}

 int query(int left, int right, int l, int r, int rt)
{
	if(l == left && r == right) return sum[rt];
	
	int mid = (l + r) >> 1;
	if(right <= mid) return query(left, right, l,mid,rt<<1);
	else if(left > mid) return query(left, right, mid+1,r,rt<<1|1);
	else return query(left, mid, l,mid,rt<<1) + query(mid + 1, right, mid+1,r,rt<<1|1);
}

int main()
{
	int n;
	scanf("%d",&n);
	int x,y;
	for(int i=0;i<n;i++)
	{
		scanf("%d%d",&x,&y);
		int temp=query(0,x,0,maxn-1,1);
		level[temp]++;
		update(x,0,maxn-1,1);
	}
	for(int i=0;i<n;i++)
	printf("%d\n",level[i]);
	return 0;
}

//poj 2352 Stars  树状数组 
#include <iostream>
#include <string.h>
using namespace std;
const int maxn = 200000+20;
int n;
int a[maxn],ans[maxn];
int lowbit(int x)
{
    return x&(-x);
}
int cal(int t)//计算1-t的和
{
    int sum=0;
    while(t>0)
    {
        sum+=a[t];
        t-=lowbit(t);
    }
    return sum;
}
void add(int x,int v)//在x的位置加上v
{
    while(x<=maxn)
    {
        a[x]+=v;
        x+=lowbit(x);
    }
}
int main()
{
	int k,x,y,n;
	while(cin>>k)
	{
	memset(a,0,sizeof(a));
	memset(ans,0,sizeof(ans));
	n=k;
	for(int i=0;i<n;i++)
	{
	cin>>x>>y;
	ans[cal(x+1)]++;
	add(x+1,1);
    }
    for(int i=0;i<n;i++)
    cout<<ans[i]<<endl;
}
	
}

下面是树状数组做法

//poj 2352 Stars  树状数组 
#include <iostream>
#include <string.h>
using namespace std;
const int maxn = 200000+20;
int n;
int a[maxn],ans[maxn];
int lowbit(int x)
{
    return x&(-x);
}
int cal(int t)//计算1-t的和
{
    int sum=0;
    while(t>0)
    {
        sum+=a[t];
        t-=lowbit(t);
    }
    return sum;
}
void add(int x,int v)//在x的位置加上v
{
    while(x<=maxn)
    {
        a[x]+=v;
        x+=lowbit(x);
    }
}
int main()
{
	int k,x,y,n;
	while(cin>>k)
	{
	memset(a,0,sizeof(a));
	memset(ans,0,sizeof(ans));
	n=k;
	for(int i=0;i<n;i++)
	{
	cin>>x>>y;
	ans[cal(x+1)]++;
	add(x+1,1);
    }
    for(int i=0;i<n;i++)
    cout<<ans[i]<<endl;
}
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值