Problem Description:
Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, ...
where D
is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D
in the 1st number, and hence it is D1
; the 2nd number consists of one D
(corresponding to D1
) and one 1 (corresponding to 11), therefore the 3rd number is D111
; or since the 4th number is D113
, it consists of one D
, two 1’s, and one 3, so the next number must be D11231
. This definition works for D
= 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D
.
Input Specification:
Each input file contains one test case, which gives D
(in [0, 9]) and a positive integer
N
N
N (
≤
40
\leq 40
≤40), separated by a space.
Output Specification:
Print in a line the Nth number in a look-and-say sequence of D
.
Sample Input:
1 8
Sample Output:
1123123111
Problem Analysis:
注意第 n + 1 n + 1 n+1 项统计的是第 n n n 项每个字符连续出现的个数。
Code
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
int n, d;
cin >> d >> n;
string cur = to_string(d);
for (int k = 0; k < n - 1; k ++ )
{
string next;
for (int i = 0; i < cur.size();)
{
int j = i + 1;
while (j < cur.size() && cur[j] == cur[i]) j ++ ;
next += cur[i] + to_string(j - i);
i = j;
}
cur = next;
}
cout << cur << endl;
return 0;
}