#1089. Insert or Merge【排序】

原题链接

Problem Description:

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N N N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

Problem Analysis:

本题需要先修 归并排序插入排序 的知识。

按照题目要求找出两段区间的分界点,然后进行下一轮迭代即可。

注意其中插入排序满足严格的两段性,即前半段是完成排序的区间,后半段是未完成排序且与原数组位置保持一致的区间。

而归并排序这里则是采用了迭代的方式,分组然后组内排序,分组大小按照 2 , 4 , 6 , ⋯   , 2 n 2, 4, 6, \cdots, 2^n 2,4,6,,2n 递增,不满组大小的视为一组,直到整个数组排序完成结束。

Code

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 110;

int n;
int a[N], b[N];
    
bool check()
{
    for (int i = 1; i <= n; i ++ )
        if (a[i] != b[i])
            return false;
    return true;
}

int main()
{
    cin >> n;
    for (int i = 1; i <= n; i ++ ) cin >> a[i];
    for (int i = 1; i <= n; i ++ ) cin >> b[i];
    
    int p = 2;
    while (p <= n && b[p] >= b[p - 1]) p ++ ;
    
    int k = p;
    while (p <= n && a[p] == b[p]) p ++ ;
    if (p == n + 1)
    {
        puts("Insertion Sort");
        sort(b + 1, b + k + 1);
        cout << b[1];
        for (int i = 2; i <= n; i ++ ) cout << ' ' << b[i];
        cout << endl;
    }
    else
    {
        puts("Merge Sort");
        int k = 1;
        while (true)
        {
            bool match = check();
            
            int len = 1 << k;
            for (int i = 1; i <= n; i += len)
                sort(a + i, a + min(n + 1, i + len));
            if (match) break;
            k ++ ;
        }
        
        cout << a[1];
        for (int i = 2; i <= n; i ++ ) cout << ' ' << a[i];
        cout << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值