杭电oj1969 pie(二分法)

50 篇文章 0 订阅
3 篇文章 0 订阅

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6614    Accepted Submission(s): 2506


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655
 

题意:有m+1个人和n个饼,现在分这些饼,要求每个饼的体积一样(每个饼都是高为1的柱体,所以说求体积就是求底面积)。问你能分的最大体积(就是底面积)。
#include<stdio.h>
#include<math.h>
#define PI acos(-1.0)//定义PI的固定格式记死!!!!! 
double a[10010];//全局变量 
int n,m;
int fun(double x)
{
	int i,s=0;
	for(i=0;i<n;i++)
	{
		s=s+(int)(a[i]/x) ;//把每个pie的体积都除以要找的mid 
	}
	if(s>=m)//说明mid小了 l=mid 
	return 1;
	else
	return 0;
}
int main()
{
	int T,i,R;
	double sum,max,l,mid,r;
	scanf("%d",&T);
	while(T--)
	{
	scanf("%d%d",&n,&m);//有n个饼,m个朋友 
				m=m+1;
				sum=0;
			for(i=0;i<n;i++)
			{
				scanf("%d",&R);
				a[i]=(double)PI*R*R;//把每个pie的体积存到数组里 
				sum=sum+a[i];
			}
			max=sum/m;
			l=0;
			r=max;
			while((r-l)>1e-6)//精度要大于1e-6 
			{
			mid=(l+r)/2;
			if(fun(mid))
			l=mid;
			else
			r=mid;
			}
			printf("%.4lf\n",l);//输出l 
		}
		return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值