【2017 ACM/ICPC Asia Regional Qingdao Online 1008】hdu 6213 Chinese Zodiac

10 篇文章 0 订阅

Chinese Zodiac

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 98    Accepted Submission(s): 74


Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.
 

Input
The first line of input contains an integer T (1T1000)   indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
  
  
3 ox rooster rooster ox dragon dragon
 

Sample Output
  
  
8 4 12
 

题目大意:

一个女的找了一个比自己小的丈夫,没有人知道他们的年领差,但是知道他们的生肖,问女的至少比男的大多少岁

如果两人属相相同,肯定大一轮,就是12

如果女的属相比男的靠后,则就是12-(女的属相-男的属相)

如果女的属相比男的靠前,则就是(男的属相-女的属相)

#include<iostream>
#include<string>
#include<map>
#include<cmath>
using namespace std;
int main()
{
    map<string, int>m;
    m["rat"] = 1;
    m["ox"] = 2;
    m["tiger"] = 3;
    m["rabbit"] = 4;
    m["dragon"] = 5;
    m["snake"] = 6;
    m["horse"] = 7;
    m["sheep"] = 8;
    m["monkey"] = 9;
    m["rooster"] = 10;
    m["dog"] = 11;
    m["pig"] = 12;

    int t;
    cin >> t;
    while (t--)
    {
        string s1, s2;
        cin >> s1 >> s2;
        if (m[s1] == m[s2]) ///生肖一样,两人至少差一轮。
        {
            cout << 12 << endl;
        }
        else if (m[s1] > m[s2])
        {
            cout << 12 - abs(m[s1] - m[s2]) << endl;
        }
        else
        {
            cout << abs(m[s1] - m[s2]) << endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值