1008Chinese Zodiac

Problem Description

The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year
cycle, each year in the cycle related to an animal sign. These signs
are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey,
rooster, dog and pig. Victoria is married to a younger man, but no one
knows the real age difference between the couple. The good news is
that she told us their Chinese Zodiac signs. Their years of birth in
luner calendar is not the same. Here we can guess a very rough
estimate of the minimum age difference between them. If, for instance,
the signs of Victoria and her husband are ox and rabbit respectively,
the estimate should be 2 years. But if the signs of the couple is the
same, the answer should be 12 years.

Input

The first line of input contains an integer T (1≤T≤1000) indicating
the number of test cases. For each test case a line of two strings
describes the signs of Victoria and her husband.

Output

For each test case output an integer in a line.

Sample Input

3
ox rooster
rooster ox
dragon dragon

Sample Output

8
4
12

心得:
比赛过程中,我写的AC的程序是下面这个。比赛结束后我发现大佬们用的都是map容器,并没有用二维数组。

映射:map
map就是从键(key)到值(value)的映射。因为重载了[]运算符,map像是数组的“高级版”。例如可以用一个map<string,int>month_name来表示“月份名字到月份编号”的映射,然后用month_name[“July”]=7这样的方式来赋值。

我的代码:

#include <iostream>
#include <string.h>
using namespace std;
int main()
{
    char age[12][12]={"rat", "ox", "tiger", "rabbit", "dragon", "snake", "horse", "sheep", "monkey", "rooster", "dog", "pig"},str1[12],str2[12];
    int t;
    cin>>t;
    while(t--)
    {
        int cnt1,cnt2,res;
        cin>>str1>>str2;
        for(int i=0;i<12;i++)
        {
            if(strcmp(age[i],str1)==0)
                cnt1=i;
            if(strcmp(age[i],str2)==0)
                cnt2=i;
        }
        res=cnt2-cnt1;
        if(res<0)
            res+=12;
        if(res==0)
            res=12;
        cout<<res<<endl;
    }
}

大佬的代码(借助map):

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
#include<string>
using namespace std;
map<string,int> M;
int main()
{
    M["rat"]=1;
    M["ox"]=2;
    M["tiger"]=3;
    M["rabbit"]=4;
    M["dragon"]=5;
    M["snake"]=6;
    M["horse"]=7;
    M["sheep"]=8;
    M["monkey"]=9;
    M["rooster"]=10;
    M["dog"]=11;
    M["pig"]=12;
    int n;
    cin>>n;
    while(n--)
    {
        string str1,str2;
        cin>>str1>>str2;
        int x=M[str2]-M[str1];
        x=(x+12)%12;
        if(x==0) x=12;
        cout<<x<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值