HDU6213 Chinese Zodiac

Chinese Zodiac


Time Limit: 1000/1000 MS (Java/Others)  

 Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 98  

 Accepted Submission(s): 74


Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be years. But if the signs of the couple is the same, the answer should be years.
 

Input
The first line of input contains an integer   indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
  


 3
ox rooster
rooster ox
dragon dragon
  



 

Sample Output
  

8
4
12
 


题意:

维多利亚嫁给年轻男性,已知他们的生肖,求最小的年龄差

输入一个整数,接着每一行输入2个生肖英语

输出最小年龄差

思路

1.生肖相同,至少差12岁

2.女的生肖在后面,女的在前一轮,男的在接下来后一轮,手写算一下样例。

因为2次减法会少算一次开始

结果是(11 - 女的下标 )+ (男的下标- 0 )+ 1     =  12 - 女 + 男

3.男的生肖在后面,都在一轮生肖里面。

结果直接男的数组下标 - 女的数组下标 。(0~11 和 1~12 剪出来效果一样)

#include <iostream>
#include <string>

using namespace std;
// HDU 6213
//2017 icpc 青岛网络赛 1008
const string zodiac[12] = {"rat", "ox", "tiger", "rabbit", "dragon", "snake", "horse", "sheep", "monkey", "rooster", "dog", "pig"};

int age_gap(string str1, string str2)
{
    int num1, num2;
    for (int i = 0; i < 12; i++)
    {
        if (zodiac[i] == str1)
            num1 = i;
        if (zodiac[i] == str2)
            num2 = i;
    }
    if (num1 == num2)
        return 12;
    else
        return num1 < num2 ? num2 - num1 : 12 - num1 + num2;
}

int main()
{
    int num;
    string str1, str2;
    cin >> num;
    while (num--)
    {
        cin >> str1 >> str2;
        cout << age_gap(str1, str2) << endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值