训练赛补题---Carries 思维 + 二分

Carries
frog has n integers a1,a2,…,ana1,a2,…,an, and she wants to add them pairwise.

Unfortunately, frog is somehow afraid of carries (进位). She defines hardness h(x,y)h(x,y) for adding xx and yy the number of carries involved in the calculation. For example, h(1,9)=1,h(1,99)=2h(1,9)=1,h(1,99)=2.

Find the total hardness adding nn integers pairwise. In another word, find
∑1≤i<j≤nh(ai,aj)
∑1≤i<j≤nh(ai,aj)
.

Input
The input consists of multiple tests. For each test:

The first line contains 11 integer nn (2≤n≤1052≤n≤105). The second line contains nn integers a1,a2,…,ana1,a2,…,an. (0≤ai≤1090≤ai≤109).

Output
For each test, write 11 integer which denotes the total hardness.

Sample Input
2
5 5
10
0 1 2 3 4 5 6 7 8 9
Sample Output
1
20

原先一直想着单个位进行处理,但位与位之间会有联系,这就很难受,所以没想到好的做法。
首先应该想到用O(n)或O(nlogn)复杂度的算法解决;
对于两个数a,b的第k位是否进位,按照公式如果满足这个a % 10^k + b % 10 ^k >= 10 ^k
那么会产生进位;
这样每个数对10^k进行取模后进行排序,接着就可以遍历每个数,然后二分边界就可以得出当前进位数;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second
const int MAXN = 1e5 + 5;

int n;
int num[MAXN];
int ans[MAXN];

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i = 0;i < n;++i){
            scanf("%d",&num[i]);
        }
        LL sum = 0;
        for(int i = 0;i < 9;++i){
            int m = (int)pow(10,i + 1);
            for(int j = 0;j < n;++j){
                ans[j] = num[j] % m;
            }
            sort(ans,ans + n);
            for(int j = n - 1;j >= 0;--j){
                int t = lower_bound(ans,ans + j,m - ans[j]) - ans;
                sum += (j - t);
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值