HDU Simpsons’ Hidden Talents

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
   
   
clinton homer riemann marjorie
 

Sample Output
   
   
0 rie 3
 
求一个串,它是串1的前缀,也是串2的后缀,那么可以用KMP实现。
//直接用p和s去匹配,注意即使p全部匹配了工作也可能还没完,必须把s串匹配到最后,记录真正的有效长度。如果存在公共部分,那么一定是s串的后缀。

#include<stdio.h>
#include<string.h>

char p[50010],s[50010];

int next[50010];

int cnt;

void get_next()
{
next[0]=-1;
int j=0,k=-1;
int len=strlen(p);
while(j<len)
{
if(k==-1 || p[j] == p[k])
{
j++;
k++;
next[j]=k;
}
else
k=next[k];
}
}

int Kmp()
{
int i=0,k=0;
get_next();
int len=strlen(s);
while(i<len)
{
if(k==-1 || s[i]==p[k])
{
i++;
k++;
cnt=k;
}
else
k=next[k];
}
}

int main()
{
while(~scanf("%s%s",p,s))
{
cnt=0;
Kmp();
if(cnt==0)
printf("0\n");
else
{
for(int i=0;i<cnt;i++)
printf("%c",p[i]);
printf(" %d\n",cnt);
}
}
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值