1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include <iostream>

using namespace std;

int main()
{
    int a,b,c;
    cin >> a >> b;
    c = a + b;
    string sum = to_string(c);
    string res;
    for(int i = sum.size()-1,j=0;i>=0;i--){
        res = sum[i] + res;
        j++;
        if(j%3==0&&sum[i-1]!='-'&&i) res = ',' + res;
    }
    cout << res << endl;
    return 0;
}

总结

1. to_string() 直接转字符串

2. 关键是加逗号的条件判断

        2.1 从后向前每3个加一个

        2.2 如果是正数,前面不要加

        2.3 如果是负数,提前检测,不要加

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值