1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2… NKaNK

where K is the number of nonzero terms in the polynomial, Ni and aNi
(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

结尾无空行
Sample Output:

3 2 1.5 1 2.9 0 3.2

处理多项式的方法,就是设置一个题目要求的最高次数的数组。唯一可能的问题是确定最高非0项是谁,但是这题不需要。因为要求输出所有非0项。

比较坑的地方在于

1: 如果多项式非0项是0,则输出0

下次输出的时候注意,直接在开始特殊输出,然后结尾一个一个接上去。

比如a 然后接上若干个’ b’

2:多项式加法导致最高项改变(如果用最高次处理法可以避免)

#include<iostream>
using namespace std;
void read(float A[]){
    int K;
    cin>>K;
    for(int i=0;i<K;i++){
        int N;
        cin>>N;
        cin>>A[N];
    }
}
int main(){
    float A[1001]={0};
    float B[1001]={0};
    read(A);
    read(B);
    int k=0;
    for(int i=0;i<1001;i++){
        A[i]+=B[i];
        if(A[i]!=0) k++;
    }
    cout<<k;
    for(int i=1000;i>=0;i--){
        if(!A[i]) continue;
        printf(" %d %.1f",i,A[i]);//#6 0
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值