1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

结尾无空行
Sample Output:

0 1

结尾无空行

题目大意:给定一颗树,按照层序输出每层的叶子节点个数

1: 一开始我想的是用二维数组进行存储,好处是找根和找叶子都比较方便。但是题目固定了根是1,因此用队列数组存储更方便,因为判断叶子更快

2: 一开始我想的是判断孩子是否是叶子,正确的思路是判断该节点是否是叶子。

3: 第一种思路是遍历整棵树,同时记录该节点到达了哪一层,然后判断该节点是否是叶子,在该层的总数上修改

第二种思路是按照广度优先进行遍历(此时正好是层序),但是需要知道一层何时结束,因此在每一层结束放置一个-1代表新的层开始。

DFS

#include<iostream>
#include<queue>
using namespace std;
int N,M;
vector<int> V[501];
queue<int> q;
vector<int> ans;
int main(){
    cin>>N>>M;
    for(int i=0;i<M;i++){
        int v,k;
        cin>>v>>k;
        for(int j=0;j<k;j++){
            int c;
            cin>>c;
            V[v].push_back(c);
        }
    }
    q.push(1);
    q.push(-1);
    int num=0;
    while(1){
        int it=q.front();
        q.pop();
        if(it==-1){
            ans.push_back(num);
            num=0;
            if(q.empty()) break;
            else q.push(-1);
            continue;
        }
        if(V[it].size()==0) num++;
        for(int child:V[it]){
            q.push(child);
        }
    }
    cout<<ans[0];
    for(int i=1;i<ans.size();i++){
        cout<<" "<<ans[i];
    }
}

WFS

#include<iostream>
#include<queue>
using namespace std;
int N,M;
vector<int> V[501];
queue<int> q;
vector<int> ans;
int dfs(int level, int root){
    int num=(V[root].size()==0)?1:0;
    if(level==ans.size()) ans.push_back(num);
    else ans[level]+=num;
    for(int child:V[root]){
        dfs(level+1,child);//此处必须是全部孩子
    }
}
int main(){
    cin>>N>>M;
    for(int i=0;i<M;i++){
        int v,k;
        cin>>v>>k;
        for(int j=0;j<k;j++){
            int c;
            cin>>c;
            V[v].push_back(c);
        }
    }
    dfs(0, 1);
    cout<<ans[0];
    for(int i=1;i<ans.size();i++){
        cout<<" "<<ans[i];
    }
}

可以看出DFS实现起来比较方便,因此还是考虑DFS和递归。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值