1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10
4 ) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:
For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

感想

1: 这题和那个排队很类似,区别在于上一题是同时到达,这题不是同时的。但是思路还是类似,一个结构体记录开始执行的时间,每一个人开始执行的时间是该窗口上一个人开始执行时间+执行时间

2: 开始执行的时间-到达的时间(如果是正数的话)

3: 对于最后 一个点,对于在17:00前到但是排到了17:00后的人,也得算排队时间

4: 每次更新这个人开始执行的时间即可。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
class Cus {
public:
    int t, P, W;
    Cus(int HH, int MM, int SS, int P):P(P*60){
        this->t = HH * 3600 + MM * 60 + SS; 
    }
    static bool cmp(Cus a, Cus b) { return a.t < b.t; }
};
int main() {
    int N, K;
    cin >> N >> K;
    vector<Cus> Win[100];
    vector<Cus> CusList;
    for (int i = 0; i < N; i++) {
        int HH, MM, SS, P;
        scanf("%d:%d:%d %d",&HH,&MM,&SS,&P);
        if (HH > 17 || (HH == 17 && (MM || SS))) continue;
        CusList.push_back(Cus(HH, MM, SS, P));
    }
    sort(CusList.begin(), CusList.end(), Cus::cmp);

    for (auto it=CusList.begin(); it!=CusList.end(); it++) {
        int Min = 0xffffff;//找一个最快结束的窗口
        int CurWin = -1;
        for (int j = 0; j < K; j++) {
            if (Win[j].empty()) { 
                CurWin = -1;
                if (it->t < 8 * 3600) {
                    it->W =  8 * 3600 - it->t;
                    it->t = 8 * 3600;//修改开始的时间
                }
                else {
                    it->W = 0;//到达晚于8:00, 不用等待
                }
                Win[j].push_back(*it);
                break;
            }
            else if (Win[j][0].t + Win[j][0].P < Min) {
                Min = Win[j][0].t+ Win[j][0].P;
                CurWin = j;
            }
        }

        if (CurWin == -1) continue;
        int Diff = Win[CurWin][0].t + Win[CurWin][0].P - it->t;
        it->W = 0;
        if (Diff > 0) {
            it->W = Diff;//来早了必须等待
            it->t = Win[CurWin][0].t + Win[CurWin][0].P;
        }
        Win[CurWin][0] = *it;
    }
    float Wait = 0;
    for (int i = 0; i < CusList.size(); i++) {
        Wait += CusList[i].W;
    }
    printf("%.1f", Wait / (60 * CusList.size()));
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值