杭电1503 LCS+字符串合并

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2998    Accepted Submission(s): 1534
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
  
  
apple peach ananas banana pear peach
 

Sample Output
  
  
appleach bananas pearch
 

题意:给出两个字符串,要求合并,但公共子串部分只输出一次。

思路:找出两个串的LCS,存在第三个串中,然后按序依次输出三个串中需要输出的部分。输出时比较难处理,第三个串S3用结构体存储,结构体还包括i,j分别代表公共子串各字符在S1串和S2串的位置。

AC代码:

/*不能保证所述全部正确,如有不足之处,还请前辈指出*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char s1[1005],s2[1005];
int dp[1005][1005];
struct ss
{
    int i,j;
    char c;
}s3[1005];
int main()
{
   // freopen("D://in.txt","r",stdin);
    int l1,l2,k=0;
    while(~scanf("%s %s",s1,s2))
    {
        l1=strlen(s1);
        l2=strlen(s2);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=l1;i++)
        {
            for(int j=1;j<=l2;j++)
            {
                if(s1[i-1]==s2[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
            }
        }
        k=0;
        for(int i=l1,j=l2;i>=1&&j>=1;)
        {
            if(s1[i-1]==s2[j-1])
            {
                s3[k].c=s1[i-1];
                s3[k].i=i-1;
                s3[k].j=j-1;
                i--;
                j--;
                k++;
            }
            else if(dp[i][j-1]>dp[i-1][j])
                j--;
            else
                i--;
        }
        int i=0,j=0;
        for(k--;k>=0;--k)
        {
            for(;s3[k].i!=i;i++)
                printf("%c",s1[i]);
            for(;s3[k].j!=j;j++)
                printf("%c",s2[j]);
            printf("%c",s3[k].c);
            ++i,++j;
        }
        for(;s1[i]!='\0';i++)
            printf("%c",s1[i]);
        for(;s2[j]!='\0';j++)
            printf("%c",s2[j]);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值