杭电1158 DP

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5128    Accepted Submission(s): 2191


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
  
  
3 4 5 6 10 9 11 0
 

Sample Output
  
  
199
 

题意:老板知道雇佣一个工人的花费,工人月薪,辞去一个工人的花费。老板要做一项工程,每个月有最低工人人数要求,多余工人不打工但也拿月薪,让你帮老板求出完成这个工程的最低花费。

思路:用一个二维数组表示状态,dp[ j ][ i ]表示第 i 个月雇佣 j 个工人的最低花费。

三重循环遍历:

i :1——>m(最多需要月数)

j : a[i](第 i 个月最低人数) ——>maxn(总的最多人数)

k:a[i-1] ——> maxn

当k>j时花费为dp[k][i-1]+j*s+(j-k)*h ;当k<j时花费为dp[k][i-1]+j*s+(k-j)*f。通过k循环遍历,求出每次dp[ j ][ i ]的最小值。


AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define INF 0xFFFFFF
using namespace std;
int a[13],dp[10050][13];
int main()
{
    //freopen("D://in.txt", "r", stdin);
    int min1,m,h,s,f;
    while(~scanf("%d",&m)&&m)
    {
        scanf("%d %d %d",&h,&s,&f);
        int maxn=-1;
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
            maxn=max(maxn,a[i]);
        }
        for(int j=a[1];j<=maxn;j++)
            dp[j][1]=j*(h+s);
        for(int i=2;i<=m;i++)
        {
            for(int j=a[i];j<=maxn;j++)
            {
                min1=INF;
                for(int k=a[i-1];k<=maxn;k++)
                    if(j>=k)
                        min1=min(min1,dp[k][i-1]+j*s+(j-k)*h);
                    else
                        min1=min(min1,dp[k][i-1]+j*s+(k-j)*f);
                dp[j][i]=min1;
            }
        }
        min1=INF;
        for(int i=a[m];i<=maxn;i++)
            min1=min(min1,dp[i][m]);
        printf("%d\n",min1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值