POJ2955 区间DP

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6350 Accepted: 3399

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source


题意:找出匹配括号的数量。

思路:dp[ i ][ j ]表示从str[ i ]到str[ j ]之间的括号匹配数量。

则 if(str[ i ] 匹配 str[ j ]) dp[ i ][ j ] = dp[ i+1 ][ j-1 ]+2 ;

然后每一次的dp[ i ][ j ]都通过dp[ i ][ x ]+dp[ x ][ j ]找出最大值。


AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
char str[105];
int dp[105][105];
int match(char a,char b)
{
    if(a=='('&&b==')')
        return 2;
    else if(a=='['&&b==']')
        return 2;
    return 0;
}
int main()
{
    //freopen("D://in.txt", "r", stdin);
    while(~scanf("%s",str))
    {
        if(strcmp(str,"end")==0)
            break;
        int len=strlen(str);
        memset(dp,0,sizeof(dp));
        for(int k=1;k<len;k++)
        {
            for(int i=0,j=k;j<len;i++,j++)
            {
                dp[i][j]=dp[i+1][j-1]+match(str[i],str[j]);
                for(int x=i;x<j;x++)
                    dp[i][j]=max(dp[i][j],dp[i][x]+dp[x+1][j]);
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值