PTA 1005 Spell It Right (20 分)(详细翻译)

背景:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

给定一个非负整数N,你的任务是计算N中所有数字的和,并用英文输出这个和的每一位数字。

输入格式:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

每个输入文件包含一个测试用例。每种情况占用一行,其中包含一个N(<= 10100)。

输出格式:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

对于每个测试用例,在一行中输出英文单词表示的和的每一位数字。两个连续的单词之间必须有一个空格,但在这一行的末尾不能有额外的空格。

输入样例:

12345

输出样例:

one five

思路:

本题不涉及算法。

C++实现代码:

#include <iostream>
#include <vector>

using namespace std;

int main()
{
    vector<string> mp = { "zero","one","two","three","four","five","six","seven","eight","nine" };
    string s;
    cin >> s;
    int sum = 0;

    for (decltype(s.length()) i = 0; i < s.length(); ++i)
        sum += (s[i] - '0');

    vector<int> ans;
    if (!sum)
        ans.push_back(0);

    while (sum)
    {
        ans.push_back(sum % 10);
        sum /= 10;
    }

    for (int i = ans.size() - 1; i >= 0; --i)
    {
        if (i == 0)
            cout << mp[ans[i]] << endl;
        else
            cout << mp[ans[i]] << " ";
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值