1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

代码: 

 

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int N,N1=0,N2=0,M[4],flag=0,temp;
    scanf("%d",&N);
    temp=N;
    for(int i=3;i>=0;i--)
    {
        M[i]=N%10;
        N/=10;
        if(i!=3&&M[i]!=M[i+1])
            flag=1;
    }
    if(flag==0)
    {
        printf("%04d - %04d = 0000",temp,temp);
        return 0;
    }
    sort(M,M+4);//从小到大排序
    for(int i=0,j=3;i<4;i++,j--)
    {
        N1=N1*10+M[i];
        N2=N2*10+M[j];
    }
    while(1)
    {
        N=N2-N1;
        printf("%04d - %04d = %04d",N2,N1,N);
        if(N==6174)
            break;
        printf("\n");
        for(int i=3;i>=0;i--)
        {
            M[i]=N%10;
            N/=10;
        }
        sort(M,M+4);
        N1=N2=0;
        for(int i=0,j=3;i<4;i++,j--)
        {
            N1=N1*10+M[i];
            N2=N2*10+M[j];
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值