POJ087 A Plug for UNIX (最大流)

A Plug for UNIX
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15962 Accepted: 5464

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

题意:

一个房间里有n种插头,现在有m个人要来,每个人的东西都需要一种类型的插头(可能是房间里没有的),然后有一家超市卖k种转换器,数量无限多,问最少有多少人插不上东西。

题解:

建立最大流模型,每一个插座类型对应一个点,然后再手动加上源点和汇点,把图建起来跑一遍最大流就好了,结果是m-maxflow.

要注意的是,m,k,n都是小于100的,但是可能都不一样啊!这样最多会有400种插座,这个得小心点。还有题目给的都是字符串,所以用map做了下映射。

代码:

//************************************************************************//
//*Author : Handsome How                                                 *//
//************************************************************************//
#include <map>
#include <vector>
#include <queue>
#include <cstring>
#include <iostream>
#include <string>
#include <cstdio>
#define fur(i,a,b) for(int i=(a);i<=(b);i++)
using namespace std;
const int inf = 100000;
const int maxn = 666;
struct Edge{
	int from, to, cap, flow;
	Edge(int u, int v, int c, int f):from(u),to(v),cap(c),flow(f){}
};

struct EdmondsKarp{
	int n, m;
	vector<Edge>edges;
	vector<int>G[maxn];
	int p[maxn];
	int a[maxn];
	
	void init(int n){
		for(int i = 0; i < n; i++) G[i].clear();
		edges.clear();
	}
	
	void AddEdge(int from, int to, int cap){
		edges.push_back(Edge(from,to,cap,0));
		edges.push_back(Edge(to,from,0,0));
		m = edges.size();
		G[from].push_back(m-2);
		G[to].push_back(m-1);
	}
	
	int Maxflow(int s, int t){
		int flow = 0;
		for(;;){
			memset(a,0,sizeof(a));
			queue<int>Q;
			Q.push(s);
			a[s] = inf;
			while(!Q.empty()){
				int x = Q.front(); Q.pop();
				for(int i = 0; i < G[x].size(); i++){
					Edge& e = edges[G[x][i]];
					if(!a[e.to] && e.cap > e.flow){
						p[e.to] = G[x][i];
						a[e.to] = min(a[x],e.cap - e.flow);
						Q.push(e.to);
					}
				}
				if(a[t]) break;
			}
			if(!a[t]) break;
			for(int u = t; u != s; u = edges[p[u]].from){
				edges[p[u]].flow += a[t];
				edges[p[u]^1].flow -= a[t];
			}
			flow += a[t];
		}
		return flow;
	}
};
map<string,int>id;
map<string,int>tmpid;
int n,m,k,cnt;
int main(){
	string tmp,tmpp;
	while(cin>>n){
		id.clear();
		tmpid.clear();
		int begin = 0, end = 450;
		EdmondsKarp solve;
		solve.init(555);
		cnt = 0;
		fur(i,1,n){
			cin>>tmp;
			id[tmp] = ++cnt;	
			solve.AddEdge(cnt,end,1);	
		}
		cin>>m;
		fur(i,1,m){
			cin>>tmpp>>tmp;
			tmpid[tmp]++;
		}
		for(map<string,int>::iterator it = tmpid.begin(); it!=tmpid.end(); it++){
			tmp = it->first;
			if(!id.count(tmp)) id[tmp] = ++cnt;
			solve.AddEdge(0,id[tmp],it->second);
		}
		cin>>k;
		fur(i,1,k){
			cin>>tmp>>tmpp;
			if(!id.count(tmp)) id[tmp] = ++cnt;
			if(!id.count(tmpp)) id[tmpp] = ++cnt;
			int id1 = id[tmp];
			int id2 = id[tmpp];
			solve.AddEdge(id1,id2,500);
		}
		cout<<m-solve.Maxflow(begin,end)<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值