poj 1087 A Plug for UNIX(最大流)

46 篇文章 0 订阅
A Plug for UNIX
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12979 Accepted: 4328

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 

C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1
 
题意:有n个插座,有m个电器,有k个转换器,每个电器对应一个插座,一个插座只能插一个电器或转换器。转换器(a,b)能使b插座变成a插座,问最后最小有多少个电器无法使用。
思路:网络最大流问题的一个经典题目,如果我们假设每件电器都消耗消耗单位功率的能量,那么能插上的最多的电器数,和电网中能量流的最大值是等价的。同时,能量有统一的起点(电源)和统一的终点(耗散掉),可以视为一个单源单汇网络。具体做法是:每个插座各自为一个结点,与汇点相连,到汇点的容量为1;每个电器与对应的插座相连,电器到插座的容量为1,且源点到每个电器的容量也为1;转换器(a,b),使a连到b,容量为INF。最后求最大流即可。

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <cmath>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll long long
#define eps 1e-6
using namespace std;

const int INF=1000000000;
const int maxn=1000;
map<string,int>type;
struct Edge
{
    int u,v,cap,flow,next;
} et[maxn*maxn];
int low[maxn],cnt[maxn],pre[maxn],dis[maxn],cur[maxn],eh[maxn];
int n,m,k,num,tot,s,t;
void init()
{
    memset(eh,-1,sizeof(eh));
    num=tot=s=0;
    t=500;
}
void add(int u,int v,int cap,int flow)
{
    Edge e={u,v,cap,flow,eh[u]};
    et[num]=e;
    eh[u]=num++;
}
void addedge(int u,int v,int cap)
{
    add(u,v,cap,0);
    add(v,u,0,0);
}
int isap(int s,int t,int n)
{
    int u,v,now,flow=0;
    memset(low,0,sizeof(low));
    memset(cnt,0,sizeof(cnt));
    memset(dis,0,sizeof(dis));
    for(int u=0;u<=n;u++) cur[u]=eh[u];
    low[s]=INF,cnt[0]=n,u=s;
    while(dis[s]<n)
    {
        for(now=cur[u];now!=-1;now=et[now].next)
        if(et[now].cap-et[now].flow&&dis[u]==dis[v=et[now].v]+1) break;
        if(now!=-1)
        {
            cur[u]=pre[v]=now;
            low[v]=min(et[now].cap-et[now].flow,low[u]);
            u=v;
            if(u==t)
            {
                for(;u!=s;u=et[pre[u]].u)
                {
                    et[pre[u]].flow+=low[t];
                    et[pre[u]^1].flow-=low[t];
                }
                flow+=low[t];
                low[s]=INF;
            }
        }
        else
        {
            if(--cnt[dis[u]]==0) break;
            dis[u]=n,cur[u]=eh[u];
            for(now=eh[u];now!=-1;now=et[now].next)
            if(et[now].cap-et[now].flow&&dis[u]>dis[et[now].v]+1)
            dis[u]=dis[et[now].v]+1;
            cnt[dis[u]]++;
            if(u!=s) u=et[pre[u]].u;
        }
    }
    return flow;
}
int main()
{
    char s1[30],s2[30];
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1; i<=n; i++)
        {
            scanf("%s",s1);
            type[s1]=++tot;
            addedge(tot,t,1);
        }
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%s %s",s1,s2);
            type[s1]=++tot;
            addedge(0,tot,1);
            if(!type[s2]) type[s2]=++tot;
            int u=type[s1],v=type[s2];
            addedge(u,v,1);
        }
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
        {
            scanf("%s %s",s1,s2);
            if(!type[s1]) type[s1]=++tot;
            if(!type[s2]) type[s2]=++tot;
            int u=type[s1],v=type[s2];
            addedge(u,v,INF);
        }
        printf("%d\n",m-isap(s,t,t+1));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值