Yaroslav and Permutations

Description
Yaroslav has an array that consists of n integers. In one second Yaroslav can swap two array elements.

Now Yaroslav is wondering if he can obtain an array where any two neighboring elements would be distinct in a finite time.

Input
The first line contains integer n (1 ≤ n ≤ 100) the number of elements in the array.

The second line contains n integers a1, a2, …, an (1 ≤ ai ≤ 1000) — the array elements.

Output
In the single line print “YES” (without the quotes) if Yaroslav can obtain the array he needs, and “NO” (without the quotes) otherwise.

Sample Input
Copy sample input to clipboard
样例1:
1
1

样例2:
3
1 1 2

样例3:
4
7 7 7 7

Sample Output
样例1:
YES
样例2:
YES
样例3:
NO

其实,此题的意思是通过交换一列数中相邻位置的数保证两个相同的数不连续出现,由于相邻交换能把一个数换到任何位置,其实只要保证这组数中相同的数不要占据一半以上即可。用数组来统计每个数字出现的次数,对出现次数最多的数加以判断即可。

#include<iostream>
#include<cstring>

using namespace std;

int a[1002];

int main()
{
    int n;
    while(cin >> n){
        memset(a, 0, sizeof(a));
        int max = 0;

        for(int i = 0; i < n; i++){
            int temp;
            cin >> temp;
            a[temp]++;
            if(a[temp] > max)
                max = a[temp];
        }

        if(max > (n+1)/2)
            cout << "NO" << endl;
        else
            cout << "YES" << endl;
    }
    return 0;
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值