【NOIP2016提高A组模拟7.15】计数

5 篇文章 0 订阅
5 篇文章 0 订阅

Description
这里写图片描述

Sample Input
2 10
Sample Output
90

The Solution

迟来的博客。。。

AlgorithmDP+高精度

我们可以设:f[i][j]表示到第 i 位,这一位为 j 的方案数。
很显然可以推出转移方程:

f[i][j]=f[i][j]+f[i1][l](j!=0andl=0)

最后答案为
i=1l(f[n][i])

Code

#include<cstdio>
#include<cstring>
#include<algorithm>
#define fo(i,a,b) for(int i=a;i<=b;i++)
#define fd(i,b,a) for(int i=b;i>=a;i--)
#define N 2000
#define ya 100000
using namespace std;
int n,m;
struct note
{
    int x[N];
}f,g,t;
note jia(note a,note b)
{
    note c;
    memset(c.x,0,sizeof(c.x));
    c.x[0]=max(a.x[0],b.x[0]);
    fo(i,1,c.x[0])
    {
        c.x[i]+=a.x[i]+b.x[i];
        c.x[i+1]+=c.x[i]/ya;
        c.x[i]%=ya;
    }
    if (c.x[c.x[0]+1]) c.x[0]++;
    return c;
}

note cheng(note a,int b)
{
    note c;
    memset(c.x,0,sizeof(c.x));
    c.x[0]=a.x[0];
    fo(i,1,c.x[0])
    {
        c.x[i]+=a.x[i]*b;
        c.x[i+1]+=c.x[i]/ya;
        c.x[i]%=ya;
    }
    if (c.x[c.x[0]+1]) c.x[0]++;
    return  c;
}

int main()
{
    scanf("%d%d",&n,&m);
    int q=m-1;
    while (q)
    {
        f.x[++f.x[0]]=q%10;
        q/=10;
    }
    fo(i,2,n)
    {
        t=f;
        f=jia(f,g);
        f=cheng(f,m-1);
        g=t;
    }
    g=jia(g,f);
    printf("%d",g.x[g.x[0]]);
    fd(i,g.x[0]-1,1) printf("%05d",g.x[i]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值