Hex-a-bonacci ————记忆化搜索

Given a code (not optimized), and necessary inputs, you have to find the output of the code for the inputs. The code is as follows:

int a, b, c, d, e, f;
int fn( int n ) {
    if( n == 0 ) return a;
    if( n == 1 ) return b;
    if( n == 2 ) return c;
    if( n == 3 ) return d;
    if( n == 4 ) return e;
    if( n == 5 ) return f;
    return( fn(n-1) + fn(n-2) + fn(n-3) + fn(n-4) + fn(n-5) + fn(n-6) );
}
int main() {
    int n, caseno = 0, cases;
    scanf("%d", &cases);
    while( cases-- ) {
        scanf("%d %d %d %d %d %d %d", &a, &b, &c, &d, &e, &f, &n);
        printf("Case %d: %d\n", ++caseno, fn(n) % 10000007);
    }
    return 0;
}

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains seven integers, a, b, c, d, e, f and n. All integers will be non-negative and 0 ≤ n ≤ 10000 and the each of the others will be fit into a 32-bit integer.

Output
For each case, print the output of the given code. The given code may have integer overflow problem in the compiler, so be careful.

Sample Input
5
0 1 2 3 4 5 20
3 2 1 5 0 1 9
4 12 9 4 5 6 15
9 8 7 6 5 4 3
3 4 3 2 54 5 4
Sample Output
Case 1: 216339
Case 2: 79
Case 3: 16636
Case 4: 6
Case 5: 54


题意:

  • 根据这段给定的代码写程序
  • 因为代码是直接递归,所以在 500ms 500 m s 内很难通过所有的测试样例的,复杂度是 O(n6) O ( n 6 )
  • 所以我们得去掉重复计算,想到用递推或者记忆化搜索

记忆化搜素:

#include<bits/stdc++.h>
using namespace std;
const int MAXN=1e6+7;
const int mod=10000007;
int f[MAXN];

int fn(int n)
{
    if(n<6)    return f[n];
    if(f[n-1])  return f[n]=f[n-1]%mod+f[n-2]%mod+f[n-3]%mod+f[n-4]%mod+f[n-5]%mod+f[n-6]%mod;
    return  f[n]=fn(n-1)%mod+fn(n-2)%mod+fn(n-3)%mod+fn(n-4)%mod+fn(n-5)%mod+fn(n-6)%mod;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    int T=t;
    while(t--)
    {
        memset(f,0,sizeof(f));
        scanf("%d %d %d %d %d %d %d",&f[0],&f[1],&f[2],&f[3],&f[4],&f[5],&n);
        printf("Case %d: %d\n",T-t,fn(n)%mod);
    }
    return 0;
}




递推:

#include<bits/stdc++.h>
using namespace std;
const int MAXN=1e6+7;
const int mod=10000007;
int f[MAXN];
int main()
{
    int t,n;
    scanf("%d",&t);
    int T=t;
    while(t--)
    {
        scanf("%d %d %d %d %d %d %d",&f[0],&f[1],&f[2],&f[3],&f[4],&f[5],&n);
        for(int i=6;i<=n;i++)
            f[i]=f[i-1]%mod+f[i-2]%mod+f[i-3]%mod+f[i-4]%mod+f[i-5]%mod+f[i-6]%mod;
        printf("Case %d: %d\n",T-t,f[n]%mod);
    }
    return 0;
}


递推还是比较快的,4ms
递归的话用了132ms

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值