Lightoj1006 Hex-a-bonacci dp

Hex-a-bonacci

 

Given a code (not optimized), and necessary inputs, you have to find the output of the code for the inputs. The code is as follows:

int a, b, c, d, e, f;
int fn( int n ) {
    if( n == 0 ) return a;
    if( n == 1 ) return b;
    if( n == 2 ) return c;
    if( n == 3 ) return d;
    if( n == 4 ) return e;
    if( n == 5 ) return f;
    return( fn(n-1) + fn(n-2) + fn(n-3) + fn(n-4) + fn(n-5) + fn(n-6) );
}
int main() {
    int n, caseno = 0, cases;
    scanf("%d", &cases);
    while( cases-- ) {
        scanf("%d %d %d %d %d %d %d", &a, &b, &c, &d, &e, &f, &n);
        printf("Case %d: %d\n", ++caseno, fn(n) % 10000007);
    }
    return 0;
}

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains seven integers, a, b, c, d, e, f and n. All integers will be non-negative and 0 ≤ n ≤ 10000 and the each of the others will be fit into a 32-bit integer.

Output

For each case, print the output of the given code. The given code may have integer overflow problem in the compiler, so be careful.

Sample Input

5

0 1 2 3 4 5 20

3 2 1 5 0 1 9

4 12 9 4 5 6 15

9 8 7 6 5 4 3

3 4 3 2 54 5 4

Sample Output

Case 1: 216339

Case 2: 79

Case 3: 16636

Case 4: 6

Case 5: 54

思路:暴搜肯定是TLE的,所以就直接搞啦,dp数组存一下以空间换时间,注意前6项也有可能超mod,所以先搞一下

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = (int)1e4 + 10;
const int mod = (int)1e7 + 7;
int f[maxn];
int main()
{
	int t,kase = 0;
	scanf("%d",&t);
	while (t--)
	{
		kase ++;
		int n;
		scanf("%d %d %d %d %d %d %d",&f[0],&f[1],&f[2],&f[3],&f[4],&f[5],&n);
		for (int i = 0;i < 6;i ++)
			f[i] %= mod;
		for (int i = 6;i <= n;i ++)
			f[i] = (f[i - 1] % mod + f[i - 2] % mod + f[i - 3] % mod + f[i - 4] % mod + f[i - 5] % mod + f[i - 6] % mod) % mod;
		printf("Case %d: %d\n",kase,f[n]);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值