HDU 2874 Connections between cities——————KMP next数组的利用

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12673    Accepted Submission(s): 5940


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3
aaa
12
aabaabaabaab
0
 

Sample Output
  
  
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4


找到一个字符串的循环节
输入n,再输入一个长度为n的字符串,从第二位开始,计算它的前缀(包括他自己)中出现过的重复字符串的个数,如aabaabaabaab的第6位的前缀aabaab,aab连续出现了两次,所以输出位数i=6,k=2

#include<bits/stdc++.h>
using namespace std;
const int MAXN=1e6+9;
char s[MAXN];
int slen,nex[MAXN];

void GetNext()
{
    int i,j;
    i=0;
    j=nex[0]=-1;
    while(i<slen)
    {
        while(-1!=j && s[i]!=s[j])  j=nex[j];
        nex[++i]=++j;
    }
}

int main()
{
    int t=1;
    while(~scanf("%d",&slen)&&slen)
    {
        scanf("%s",s);
        GetNext();
        printf("Test case #%d\n",t++);
        for(int i=1;i<=slen;i++)
        {
            int L=i-nex[i];//可能的周期串长度
            if(i!=L&&i%L==0)//保证回文串个数大于2,并且子串回文
                printf("%d %d\n",i,i/L);//回文子串的最大坐标,以及周期串的个数
        }
        printf("\n");
//            printf("next[%2d]:%d  length:%d\n",i,nex[i],i-nex[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值