PTA甲级 1071 Speech Patterns (25分)


强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

PS 今天也要加油鸭

在这里插入图片描述

题目原文

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

生词如下:

insensitive 不敏感

cops 警察

alphanumerical 字母数字混合编制的 记忆方法 alpha 字母+number数字 就是字面意思

lexicographically 辞典编纂的

题目大意:

就是给你一行话.

要你求出这行话中出现次数最多的词(可以带数字) 和他出现的次数

大小写不敏感.输出的时候,输出小写.

例如:

Can1: "Can a can can a can?  It can!"
can 5

思路如下:

用一句getline来读入完整的句子.

测试点4过不去的原因:

比如说:

Can1: "Can a can can a can?  It can

不加分隔符的代码的结果就是

can 4

因为最后没有一个结束的分隔符.这个是要写过代码的.

所以我加了一个逗号

解决办法

然后再读入的句子后面加一个 逗号作为分隔符.

也可以不加.不加就要再代码里面加一个判断.想了想还是加了.

判断更加麻烦一点.

.

代码如下:

#include<iostream>
#include<map>
#include<string>
using namespace std;
int main(void) {
	map<string, int>Data;
	string result,t,s;	//用来保存最终的结果的
	int num = -1;
	char a;
	getline(cin, s);
	s += '.';										//最后一个字符的错误.
	for (int i = 0; i < s.length(); ++i) {
		a = s[i];
		if (isdigit(a) || islower(a) || isupper(a)) {
			if (isupper(a)) a=tolower(a);
			t += a;
		}
		else if (t != "") {
			Data[t]++;
			if (Data[t] >= num) {
				num = Data[t];
				result = t;
			}
			t = "";
		}
	}
	cout << result << " " << num;
	return 0;
}

柳神的代码:

#include <iostream>
#include <map>
#include <cctype>
using namespace std;
int main() {
    string s, t;
    getline(cin, s);
    map<string, int> m;
    for(int i = 0; i < s.length(); i++) {
        if(isalnum(s[i])) {
            s[i] = tolower(s[i]);
            t += s[i];
        }
        if(!isalnum(s[i]) || i == s.length() - 1){
            if(t.length() != 0) m[t]++;
            t = "";
        }
    }
    int maxn = 0;
    for(auto it = m.begin(); it != m.end(); it++) {
        if(it->second > maxn) {
            t = it->first;
            maxn = it->second;
        }
    }
    cout << t << " " << maxn;
    return 0;
}

如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗

相信我,你也能变成光.

在这里插入图片描述

如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值