PTA甲1125 Chain the Ropes (25 point(s))

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

生词如下:

Chain 链

Ropes 栏索

halved 减半

看了一遍还是没有理解是啥意思

我是真的不理解,决定去看看柳神的题目分析

题目大意:

我是傻逼,脑子坏了,竟然没有读懂题目

就是每次两端绳子相加,然后/2,成为一个新绳子

我吐了,这题目其实蛮清楚的,是我傻逼了

思路分析:

这里我抄我柳神的了.

分析:因为所有长度都要串在一起,每次都等于(旧的绳子长度+新的绳子长度)/2,所以越是早加入绳子长度中的段,越要对折的次数多,所以既然希望绳子长度是最长的,就必须让长的段对折次数尽可能的短。所以将所有段从小到大排序,然后从头到尾从小到大分别将每一段依次加入结绳的绳子中,最后得到的结果才会是最长的结果~

代码如下:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main(void) {
	int M,T;
	scanf("%d", &M);
	vector<int> Data(M);
	for (int i = 0; i < M; ++i) {
		scanf("%d", &Data[i]);
	}
	sort(Data.begin(), Data.end());
	T = Data[0];
	for (int i = 1; i < M; ++i) {
		T = (T + Data[i])/2;
	}
	cout << T ;
}

读懂了题目,这题就有点弱智了.

但是问题是,考试的时候,我大概率是读不懂的,英文不好的

所以我还是傻逼

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值