UVA 10391(把符合单词输出,map)

Compound Words

   Time Limit: 3000ms                        Memory Limit: 131072KB

[PDF Link]

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn

题目大意:

给你一些字典里面的词语,输出有其中两个单词可以复合的复合单词。

解题思路:

输入时已经是字典序,输出不用再排顺序。


代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<map>
using namespace std;

const int maxn = 120010;
string str[maxn],str1,str2;
map <string,int> mymap;
int r = 0;
void input(){
    while(cin>>str[r++]){
        mymap[str[r-1]]=2;//也可以为别的数
    }
}

void solve(){
    for(int i=0;i<r;i++){
        str1.clear();
        str2.clear();
        for(int j=0;j<str[i].length();j++){
            str1+=str[i][j];
            if(mymap[str1]==2){
                str2=&str[i][j+1];
                if(mymap[str2]==2){
                    cout<<str[i]<<endl;
                    break;
                }
            }
        }
    }
}

int main(){
    input();
    solve();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值