【PAT】1001 A+B Format

Problem

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 ≤ a , b ≤ 1 0 6 −10^6 ≤a,b≤10^6 106a,b106 . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991



Solution

解题思路很简单,因为输入的数字绝对值最大是 1 0 6 10^6 106,因此和最大是七位数。根据和的位数向输出中增加","。这里需要注意的是c++中substrsubstring函数的区别(一开始弄错了导致debug了很久)

s.substr(pos, n):返回一个string,包含s中从pos开始的n个字符的拷贝(pos的默认值是0,n的默认值是s.size() - pos,即不加参数会默认拷贝整个s)
s.substring(start, end):将返回一个包含从 start 到最后(不包含 end )的子字符串的字符串

更加详细的区别和用法可以参见这篇博客

代码如下:

#include <iostream>
#include <string>
using namespace std;

int main(int argc, const char * argv[]) {
    int a, b, c;
    cin >> a >> b;
    c = a + b;
    string output = to_string(c);
    int length = output.length();
    if(abs(c) >= 1000 && abs(c) < 1000000){
        output = output.substr(0, length-3) + "," + output.substr(length-3);
    }else if(abs(c) >= 1000000){
        output = output.substr(0, length-6) + "," + output.substr(length-6, 3) + "," + output.substr(length-3);
    }
    cout << output << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值