杭电-oj triangle(数学找规律)

问题描述
A triangle field is numbered with successive integers in the way shown on the picture below.
在这里插入图片描述

The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller’s route.

Write the program to determine the length of the shortest route connecting cells with numbers N and M.

Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).

Output
Output should contain the length of the shortest route.

Sample Input
6 12

Sample Output
3

大致题意及思路
这是一个数学题,需要找出计算规律。
要想算出m到n的距离,需要从一个地方按行走、按左下方向走和按右下方向走,把这三个距离都加起来就得到了距离。
在这里插入图片描述
就是上图三个角度,他们之间存在线的和,比如3到13。横线的3和13之间存在两个水平线,计算方法为13那行对应末尾16开根号,为4,3对应那行末尾数字4开根号为2。两者之差为2。同理 /left也是末尾开根号,而\right,从第二行开始,是开头的开根号再加一。

代码

#include <stdio.h>
#include <math.h>
void find(int n, int &l, int &r, int &level)
{
    int i;
    level = 1;
    for (i = 1; ; i += 2)
    {
        if (n - i <= 0)
        {
            l = (n + 1) / 2;      /*左边层次*/
            r = (i - n) / 2 + 1;  /*右边层次*/
            break;
        }
        level++;  /*层次*/
        n -= i;
    }
}
 
int main()
{
    int m, n;
    int ml, mr, nl, nr, mlevel, nlevel;
    while(scanf("%d%d", &m, &n) != EOF)
    {
        find(m, ml, mr, mlevel);
        find(n, nl, nr, nlevel);
        printf("%d\n", abs(ml - nl) + abs(mr - nr) + abs(mlevel - nlevel));
    }
    return 0;
}

本篇博客仅供本人学习使用,总结归纳,如果错误,感谢您的指正。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值